Notifications
Clear all

High Cogging Torque with Iq Set to 0 - Hoverboard Motor

5 Posts
3 Users
0 Likes
81 Views
Forum 1
(@wrcman555)
Posts: 13
Eminent Member
Topic starter
 

Hi,

I'm using a solo mini for the first time to drive a 30 pole, 6.5" hoverboard motor. I am using an AMT102 incremental encoder to measure the motor position, set to 1024 PPR (lines). 

I have updated my firmware to the latest version (0000B00D).

I have been able to successfully get the motor set up in Motion Terminal, and have gotten torque, speed, and position modes to work after finding the right wiring combination.

My problem is that the motor rotation is not smooth in any of the modes, but feels very "coggy". For example, in torque mode, with the Iq set 0.0, the motor does not spin freely, but cogs along. I have tried to run the motor parameter identification multiple times, but without improvement. 

What should I try next? I have used a SOLO Uno before with the same motor, and did not see this behavior. It was very smooth.

 

Best,

Ben

 

 
Posted : 04/12/2022 5:36 pm
SOLO Team
(@milad)
Posts: 466
Illustrious Member Admin
 

@wrcman555

Could you please share a screenshot from your Motion Terminal settings?

I believe most probably your current controller Kp or Ki gains are too high ( detected after Motor ID.), so let me know about that and we'll come up with a solution.

Regards
Milad

If you found the answers helpful and you could solve your problems, please kindly verify here to help others in the future.

 
Posted : 05/12/2022 8:27 am
Forum 1
(@wrcman555)
Posts: 13
Eminent Member
Topic starter
 

@milad Hi Milad,

 

For reference, the I measured the phase to phase resistance to be 1.0 ohms, and the phase to phase inductance to be be 0.67 mH. using an LC meter.

Below is a screenshot after motor identification is run. I have the current limit set to 7 amps.

image

 

Thanks for the help!

Ben

 
Posted : 05/12/2022 2:52 pm
SOLO Team
(@milad)
Posts: 466
Illustrious Member Admin
 

@wrcman555 ,

 

Just a quick test:

- Can you reduce the current controller Kp and Ki gains to the following values and check if the cogging behavior becomes better:

Current Controller Kp = 0.12

Current controller Ki = 0.005

After changing these gains, you'd need to recycle the power of your unit, so the new gains take effect.

Milad

 

If you found the answers helpful and you could solve your problems, please kindly verify here to help others in the future.

 
Posted : 06/12/2022 2:41 pm
Forum 5
(@ndemarco)
Posts: 3
Active Member
 

Did changing the gains help with motor cogging?

Do you really have to cycle power to make the new gains effective? Can you not just reset the controller or something less drastic?

 
Posted : 21/12/2022 4:02 pm
Share: