Clear all

Unable to connect via USB, using the motion terminal

4 Posts
3 Users
Forum 1
Posts: 9
Active Member
Topic starter

Hi all, hopefully you can help me with the following problem:

I am not able to connect with the Solo Uno board using the motion terminal. That is: when I select the com port after pressing the plug in the top right, no communication is possible and the plug remains red. Several months ago, I was able to establish a connection and it is unclear to me what causes it to fail at this moment. I do not have any more debug info, because I can't find any logs. However, I already tried several things:

  • Different browser: I tried both Edge and Chrome.
  • Detaching all connections, except for the power and USB.
  • Uninstalling the driver in the windows 'Device Manager'.
  • Manually installing the USB driver I found at another forum post (attached the zip below). 

Hopefully someone can point me to a solution. Thanks!

Posted : 01/09/2023 2:27 pm
Posts: 27
Chief Member

you should be able to normally connect to your solo. 

 - When you power up your unit does it blink? (E2 blink, E1 off) If is not the case maybe you are in DFU mode, put pin #3 up.

 - If was a first connection trial I suggest to check if you are using a working USB data cable and maybe a different USB port too. 


Posted : 01/09/2023 3:44 pm
Forum 1
Posts: 9
Active Member
Topic starter

Thanks for the suggestions. The E2 LED is indeed blinking like normal. 

I just tried to connect with another laptop and that worked first try. That suggest that something on my laptop is at fault although I did not yet pinpoint the exact problem. I just noticed that in de device manager there are exclamation marks and in the properties tab it has the following error: "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)". Although, uninstalling the device and scanning for hardware changes did not solve this. 

Do you maybe have other suggestions, or have encountered this problem before?

This post was modified 4 weeks ago by tammo
Posted : 04/09/2023 2:28 pm
Posts: 546
Illustrious Member Admin

Hi @tammo,

Thanks for the update, This seems strange, the issue might be related to the hardware of your laptop (maybe the USB ports) not somehow adapting, or maybe the cable (if it has data lines or not), the latter is responsible for 99% of failures from our experience.




If you found the answers helpful and you could solve your problems, please kindly verify here to help others in the future.

Posted : 11/09/2023 8:00 am