Forum

Can't get motor run...
 
Notifications
Clear all

Can't get motor running with Solopy (canopen)

2 Posts
2 Users
0 Likes
89 Views
Forum 1
(@luczia)
New Member
Joined: 3 months ago
Posts: 1
Topic starter  

Hi,

I'm using a SOLO Pico which I try to control from a python interface through solopy and a CANAble transeiver module.
Through the USB interface, I've configured the motor (digital, pole nbr, ...) and I am able to run the motor without any issue (BLDC, sensorless). I've set the device adress to 2.

When connecting through CAN(open) the get_board_temperature(),  get_read_error_register() and get_speed_feedback() seems to be working fine (although temperature seems a dozen °C too high) but the motor in this case does not move. It doesn't seems to accept any input from set_xxxx functions).

I've tried the sensorless_brushless_speed_control.py example, adding and removing several parameters but the motor never move. Also the parameters (for example changing pole number) never update in SOLOMotion through USB.

I don't understand why, it seems that the inverter doesn't accept any input from CANOpen. And I don't read any error (get_read_error_register() is always equal to 0). I've tried to run it with or without USB connection.

Any hint in this regards ?

Thanks,

This topic was modified 2 months ago by Luczia

   
Quote
SOLO Team
(@milad)
Illustrious Member Admin
Joined: 4 years ago
Posts: 581
 

Hello @luczia,

The problem is a bit strange, so to control the speed you need to set the speed reference through the CAN bus, by doing so can you verify if the value of speed reference changes in the Motion terminal as well?

Milad

 

If you found the answers helpful and you could solve your problems, please kindly verify here to help others in the future.


   
ReplyQuote
Share: